The error, verbatim
Jump to the fix ↓ERROR: Could not find a version that satisfies the requirement torch (from versions: none)
ERROR: No matching distribution found for torch
Tested on
- Python
- 3.14.5 64-bit, 3.14.8 32-bit, 3.14.8 free-threaded, 3.15.0
- pip
- 26.1.1 / 26.2.1
- PyTorch
- 2.15.0 (latest, re-tested Oct 30), 2.14.1, nightly 2.16.0.dev
- OS
- Windows 11 Pro
Contents
PyTorch only publishes ready-made builds (wheels), never source code pip could build. So when no wheel matches your Python, your operating system and the index you’re using, pip has nothing at all to offer, and says so: from versions: none. The empty list is the clue. If the list in brackets isn’t empty, jump to cause 4.
Start by checking your Python version and whether it’s 64-bit:
python -c "import sys, platform; print(sys.version, platform.architecture()[0])"I reproduced every cause below on Windows 11 with pip 26:
| What you see | Cause |
|---|---|
(from versions: none), Python 3.15 with torch before 2.15.0 |
Python is newer than PyTorch |
(from versions: none), output ends in 32bit |
32-bit Python |
(from versions: none) with --index-url …/cu118 |
An old CUDA index |
(from versions: 2.9.0, 2.9.1, … 2.15.0) |
A pinned version too old for your Python |
You tried to install "pytorch" |
The wrong package name |
1. Your Python is newer than PyTorch
Python 3.15 came out on October 9, 2026. PyTorch 2.14.1, the latest release then, had wheels up to 3.14, so on 3.15.0 pip found none:
ERROR: Could not find a version that satisfies the requirement torch (from versions: none)
ERROR: No matching distribution found for torch
The same happened on Linux. torch 2.15.0 fixed it: it ships wheels for 3.15 on Windows, Linux and macOS. The same thing will happen again with each new Python until PyTorch catches up.
On Python 3.15, install torch 2.15.0 or newer:
pip install --upgrade torchFor a GPU build on 3.15, use the cu132 index (torch 2.15.0). The cu128 and cu129 indexes still say No matching distribution found for torch on 3.15.
If a project pins an older torch, create its environment with Python 3.14 instead:
py -V:3.14 -m venv .venv
.venv\Scripts\activate
pip install torchBefore 2.15.0, the only way onto 3.15 was PyTorch’s nightly index (pip install --pre torch --index-url https://download.pytorch.org/whl/nightly/cpu), which installed 2.16.0.dev20261012 on 3.15.0. Use the stable release now.
2. 32-bit Python
PyTorch has no 32-bit Windows builds. If the check above ends in 32bit, pip gives exactly the same error, even on a supported version like 3.14.8.
Install 64-bit Python and make the environment with it. With the Python install manager:
py install 3.14
py -V:3.14 -m venv .venv3. An old CUDA index URL
For GPU builds, the PyTorch site gives a command with --index-url https://download.pytorch.org/whl/cu…. A command copied from an old tutorial points to an index that has nothing for current Pythons. I checked each index for Python 3.14:
| Index | Newest torch for Python 3.14 |
|---|---|
cu118, cu121, cu124 |
none: (from versions: none) |
cu126 |
2.14.1 |
cu128 |
2.11.0 |
cu129 |
2.9.0 |
cu130 |
2.14.1 |
cu132 |
2.15.0 |
cpu |
2.15.0 |
Use a CUDA version that has builds for your Python, for example:
pip install torch --index-url https://download.pytorch.org/whl/cu130Your NVIDIA driver has to support that CUDA version. nvidia-smi shows the highest CUDA version your driver supports. To list what any index has for your Python, run pip index versions torch --index-url <the URL>.
4. A pinned version that’s too old for your Python
When the brackets aren’t empty, pip found torch but not the version you asked for. torch==2.1.2 and torch==2.3.1 are common pins in older projects. On Python 3.14:
ERROR: Could not find a version that satisfies the requirement torch==2.1.2 (from versions: 2.9.0, 2.9.1, 2.10.0, 2.11.0, 2.12.0, 2.12.1, 2.13.0, 2.14.0, 2.14.1, 2.15.0)
That list is every torch release with a wheel for your Python. 2.9.0 is the first one built for 3.14.
Either pin a version from that list, or keep the old pin and use the Python it was built for:
pip install "torch==2.14.1"If the project really needs torch 2.1.2, make its environment with an older Python that release has wheels for: install it with py install <version>, then create the venv with py -V:<version> -m venv .venv.
5. pip install pytorch
pytorch is not PyTorch’s package name. There is a pytorch package on PyPI, version 1.0.2, but it’s a 689-byte placeholder that only exists to stop you:
Exception: You tried to install "pytorch". The package named for PyTorch is "torch"
Install torch instead (and torchvision, torchaudio if you need them):
pip install torchHow this was tested
Windows 11 Pro, on October 12 and 13, 2026, with Python 3.14.5 (64-bit), 3.14.8 (32-bit), 3.14.8 free-threaded and 3.15.0, all from python.org through the Python install manager, each in a fresh virtual environment. The 3.15 Linux check ran on GitHub Actions’ ubuntu-latest (workflow). Every error above is the real output. Re-tested October 30 with torch 2.15.0 on Python 3.15.0 and 3.14.5 (Windows, pip 26); every 2.15.0 and cu132 result above is from that run.
— N.K., end of entry No.065